summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKali Kaneko <kali@leap.se>2013-04-30 00:19:12 +0900
committerKali Kaneko <kali@leap.se>2013-04-30 00:19:12 +0900
commit06d9e5e7714562b10c48a0482dec2acd4abee55a (patch)
tree6c1aefc8458290d4d5fb404a3a2ca6eca2ff3e2f
parent895f13225a8a0fb8f142c3d318268f652712745a (diff)
add dev version
-rw-r--r--.gitignore3
-rw-r--r--MANIFEST.in3
-rw-r--r--PKG-INFO25
-rw-r--r--cross_bdist_wininst.pycbin10283 -> 0 bytes
-rw-r--r--setup.py8
5 files changed, 14 insertions, 25 deletions
diff --git a/.gitignore b/.gitignore
index ba66091..49be68c 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,2 +1,5 @@
amalgamation
build
+*.pyc
+dist/
+MANIFEST
diff --git a/MANIFEST.in b/MANIFEST.in
index d909e8e..b8e5646 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -6,3 +6,6 @@ include doc/includes/sqlite3/*.py
include doc/sphinx/*
include doc/sphinx/.static/.keepme
include src/*.h
+include setup.py
+
+global-exclude *~ *.pyc
diff --git a/PKG-INFO b/PKG-INFO
deleted file mode 100644
index e0fdf08..0000000
--- a/PKG-INFO
+++ /dev/null
@@ -1,25 +0,0 @@
-Metadata-Version: 1.0
-Name: pysqlite
-Version: 2.6.3
-Summary: DB-API 2.0 interface for SQLite 3.x
-Home-page: http://pysqlite.googlecode.com/
-Author: Gerhard Haering
-Author-email: gh@ghaering.de
-License: zlib/libpng license
-Download-URL: http://code.google.com/p/pysqlite/downloads/list
-Description: Python interface to SQLite 3
-
- pysqlite is an interface to the SQLite 3.x embedded relational database engine.
- It is almost fully compliant with the Python database API version 2.0 also
- exposes the unique features of SQLite.
-Platform: ALL
-Classifier: Development Status :: 5 - Production/Stable
-Classifier: Intended Audience :: Developers
-Classifier: License :: OSI Approved :: zlib/libpng License
-Classifier: Operating System :: MacOS :: MacOS X
-Classifier: Operating System :: Microsoft :: Windows
-Classifier: Operating System :: POSIX
-Classifier: Programming Language :: C
-Classifier: Programming Language :: Python
-Classifier: Topic :: Database :: Database Engines/Servers
-Classifier: Topic :: Software Development :: Libraries :: Python Modules
diff --git a/cross_bdist_wininst.pyc b/cross_bdist_wininst.pyc
deleted file mode 100644
index f9fb0af..0000000
--- a/cross_bdist_wininst.pyc
+++ /dev/null
Binary files differ
diff --git a/setup.py b/setup.py
index c30ac59..ef9fe43 100644
--- a/setup.py
+++ b/setup.py
@@ -32,6 +32,7 @@ import zipfile
from types import ListType, TupleType
from distutils.core import setup, Extension, Command
+#from setuptools import setup, Extension, Command
from distutils.command.build import build
from distutils.command.build_ext import build_ext
from distutils.dep_util import newer_group
@@ -46,6 +47,9 @@ sqlite = "sqlite"
PYSQLITE_EXPERIMENTAL = False
+#DEV_VERSION = None
+DEV_VERSION = "1"
+
sources = ["src/module.c", "src/connection.c", "src/cursor.c", "src/cache.c",
"src/microprotocols.c", "src/prepare_protocol.c", "src/statement.c",
"src/util.c", "src/row.c"]
@@ -286,6 +290,9 @@ def get_setup_args():
break
f.close()
+ if DEV_VERSION:
+ PYSQLITE_VERSION += ".dev%s" % DEV_VERSION
+
if not PYSQLITE_VERSION:
print "Fatal error: PYSQLITE_VERSION could not be detected!"
sys.exit(1)
@@ -302,6 +309,7 @@ def get_setup_args():
setup_args = dict(
name="pysqlcipher",
version=PYSQLITE_VERSION,
+ #version="0.0.1",
description="DB-API 2.0 interface for SQLCIPHER 3.x",
long_description=long_description,
author="Kali Kaneko",