Update spec_helper for more consistency
authorMorgan Haskel <morgan@puppetlabs.com>
Thu, 28 Aug 2014 22:46:41 +0000 (18:46 -0400)
committerMorgan Haskel <morgan@puppetlabs.com>
Thu, 28 Aug 2014 22:46:41 +0000 (18:46 -0400)
spec/spec_helper_acceptance.rb

index d37c169..8ca20a8 100644 (file)
@@ -1,12 +1,14 @@
 require 'beaker-rspec'
 
 unless ENV['RS_PROVISION'] == 'no' or ENV['BEAKER_provision'] == 'no'
+  # This will install the latest available package on el and deb based
+  # systems fail on windows and osx, and install via gem on other *nixes
+  foss_opts = { :default_action => 'gem_install' }
+
+  if default.is_pe?; then install_pe; else install_puppet( foss_opts ); end
+
   hosts.each do |host|
-    # Install Puppet
-    if host.is_pe?
-      install_pe
-    else
-      install_puppet
+    unless host.is_pe?
       on hosts, "mkdir -p #{hosts.first['distmoduledir']}"
     end