Remove 2.7 from travis matrix
authorMorgan Haskel <morgan@puppetlabs.com>
Tue, 25 Aug 2015 23:14:04 +0000 (16:14 -0700)
committerMorgan Haskel <morgan@puppetlabs.com>
Tue, 25 Aug 2015 23:15:34 +0000 (16:15 -0700)
I believe 2.7 in the matrix is an error, this module has never claimed
support for 2.7 and 2.7 currently doesn't work (though fails in places
that are not unit tested)

.sync.yml
.travis.yml

index 02c6c83..f4b637c 100644 (file)
--- a/.sync.yml
+++ b/.sync.yml
@@ -1,11 +1,5 @@
 ---
 .travis.yml:
-  script: "\"bundle exec rake spec SPEC_OPTS='--format documentation'\""
-  extras:
-  - rvm: 1.8.7
-    env: PUPPET_GEM_VERSION="~> 2.7.0" FACTER_GEM_VERSION="~> 1.6.0"
-  - rvm: 1.8.7
-    env: PUPPET_GEM_VERSION="~> 2.7.0" FACTER_GEM_VERSION="~> 1.7.0"
 Rakefile:
   unmanaged: true
 spec/spec_helper.rb:
index 727f6e7..1155a2d 100644 (file)
@@ -16,10 +16,6 @@ matrix:
     env: PUPPET_GEM_VERSION="~> 3.0" FUTURE_PARSER="yes"
   - rvm: 2.1.6
     env: PUPPET_GEM_VERSION="~> 4.0" STRICT_VARIABLES="yes"
-  - rvm: 1.8.7
-    env: PUPPET_GEM_VERSION="~> 2.7.0" FACTER_GEM_VERSION="~> 1.6.0"
-  - rvm: 1.8.7
-    env: PUPPET_GEM_VERSION="~> 2.7.0" FACTER_GEM_VERSION="~> 1.7.0"
   allow_failures:
     - rvm: 2.1.6
       env: PUPPET_GEM_VERSION="~> 4.0" STRICT_VARIABLES="yes"