(maint) allow setting PUPPET_VERSION in acceptance
authorJustin Stoller <justin.stoller@gmail.com>
Tue, 9 Jun 2015 05:32:54 +0000 (22:32 -0700)
committerJustin Stoller <justin.stoller@gmail.com>
Tue, 9 Jun 2015 05:32:54 +0000 (22:32 -0700)
spec/spec_helper_acceptance.rb

index 9ef826a..78074f7 100644 (file)
@@ -3,7 +3,10 @@ require 'beaker-rspec'
 unless ENV['RS_PROVISION'] == 'no' or ENV['BEAKER_provision'] == 'no'
   # This will install the latest available package on el and deb based
   # systems fail on windows and osx, and install via gem on other *nixes
-  foss_opts = { :default_action => 'gem_install' }
+  foss_opts = {
+    :default_action => 'gem_install',
+    :version        => (ENV['PUPPET_VERSION'] || '3.8.1'),
+  }
 
   if default.is_pe?; then install_pe; else install_puppet( foss_opts ); end