Pending overflow depth test
authorHunter Haugen <hunter@puppetlabs.com>
Wed, 18 Jun 2014 16:43:59 +0000 (09:43 -0700)
committerHunter Haugen <hunter@puppetlabs.com>
Wed, 18 Jun 2014 16:43:59 +0000 (09:43 -0700)
This test is pending as git cannot handle the overflow correctly, though
vcsrepo handles it fine.

spec/acceptance/beaker/git/shallow_clone/negative/shallow_clone_overflow_depth.rb

index a40a204..5da9fd7 100644 (file)
@@ -3,6 +3,8 @@ test_name 'C3606 - shallow clone repo depth overflow 64bit integer'
 # Globals
 repo_name = 'testrepo_shallow_clone'
 
 # Globals
 repo_name = 'testrepo_shallow_clone'
 
+pending_test("The overflow can't be handled on some git versions")
+
 hosts.each do |host|
   tmpdir = host.tmpdir('vcsrepo')
   step 'setup - create repo' do
 hosts.each do |host|
   tmpdir = host.tmpdir('vcsrepo')
   step 'setup - create repo' do