Autorequire Package['mercurial']
authorMatthias Pigulla <mp@webfactory.de>
Sat, 15 Aug 2015 13:45:39 +0000 (15:45 +0200)
committerMatthias Pigulla <mp@webfactory.de>
Sat, 15 Aug 2015 13:45:39 +0000 (15:45 +0200)
Along the lines of 2b190756260346931b8f9a0dda8afc0c815710d6, if the
Mercurial package is being managed, it stands to reason that the Mercurial
package should be installed before trying to potentially manage Mercurial
repositories using vcsrepo resources.

This commit adds an autorequire to the vcsrepo type that reflects the
above premise.

lib/puppet/type/vcsrepo.rb

index e5dfbb5..ed5d55a 100644 (file)
@@ -229,6 +229,6 @@ Puppet::Type.newtype(:vcsrepo) do
   end
 
   autorequire(:package) do
-    ['git', 'git-core']
+    ['git', 'git-core', 'mercurial']
   end
 end