Merge pull request #262 from webfactory/autorequire-hg
authorDavid Schmitt <david.schmitt@puppetlabs.com>
Thu, 17 Sep 2015 17:59:59 +0000 (18:59 +0100)
committerDavid Schmitt <david.schmitt@puppetlabs.com>
Thu, 17 Sep 2015 17:59:59 +0000 (18:59 +0100)
Autorequire Package['mercurial']

1  2 
lib/puppet/type/vcsrepo.rb

@@@ -227,14 -227,8 +227,14 @@@ Puppet::Type.newtype(:vcsrepo) d
    newparam :conflict do
      desc "The action to take if conflicts exist between repository and working copy"
    end
 +  
 +  newparam :trust_server_cert do
 +    desc "Trust server certificate"
 +    newvalues(:true, :false)
 +    defaultto false
 +  end
  
    autorequire(:package) do
-     ['git', 'git-core']
+     ['git', 'git-core', 'mercurial']
    end
  end