1.3.1 prep
authorMorgan Haskel <morgan@puppetlabs.com>
Fri, 24 Jul 2015 22:28:24 +0000 (15:28 -0700)
committerMorgan Haskel <morgan@puppetlabs.com>
Fri, 24 Jul 2015 22:28:24 +0000 (15:28 -0700)
CHANGELOG.md
metadata.json

index ad10e97..7d1060c 100644 (file)
@@ -1,6 +1,16 @@
 # Change Log
 All notable changes to this project will be documented in this file. This project adheres to [Semantic Versioning](http://semver.org/).
 
+## [1.3.1] - 2015-07-28 Supported Release
+###Summary
+This release includes a number of bugfixes along with some test updates.
+
+### Fixed
+- Fix for detached HEAD on git 2.4+
+- Git provider doesn't ignore revision property when depth is used (MODULES-2131)
+- Test fixes
+- Check if submodules == true before calling update_submodules
+
 ## [1.3.0] - 2015-05-19 Supported Release
 ### Summary
 This release adds git provider remote handling, svn conflict resolution, and fixes the git provider when /tmp is mounted noexec.
@@ -125,6 +135,7 @@ our many contributors for all of these fixes!
 - CVS:
  - Documented the "module" attribute.
 
+[1.3.1]: https://github.com/puppetlabs/puppetlabs-vcsrepo/compare/1.3.0...1.3.1
 [1.3.0]: https://github.com/puppetlabs/puppetlabs-vcsrepo/compare/1.2.0...1.3.0
 [1.2.0]: https://github.com/puppetlabs/puppetlabs-vcsrepo/compare/1.1.0...1.2.0
 [1.1.0]: https://github.com/puppetlabs/puppetlabs-vcsrepo/compare/1.0.2...1.1.0
index ef74e86..1552840 100644 (file)
@@ -1,12 +1,15 @@
 {
   "name": "puppetlabs-vcsrepo",
-  "version": "1.3.0",
+  "version": "1.3.1",
   "author": "Puppet Labs",
   "summary": "Puppet module providing a type to manage repositories from various version control systems",
   "license": "GPLv2",
   "source": "https://github.com/puppetlabs/puppetlabs-vcsrepo",
   "project_page": "https://github.com/puppetlabs/puppetlabs-vcsrepo",
   "issues_url": "https://tickets.puppetlabs.com/browse/MODULES",
+  "dependencies": [
+  
+  ],
   "operatingsystem_support": [
     {
       "operatingsystem": "RedHat",
   "requirements": [
     {
       "name": "pe",
-      "version_requirement": "3.x"
+      "version_requirement": ">= 3.0.0 < 2015.3.0"
     },
     {
       "name": "puppet",
-      "version_requirement": "3.x"
+      "version_requirement": ">= 3.0.0 < 5.0.0"
     }
-  ],
-  "dependencies": [
-  
   ]
 }