Update modulesync_config [a3fe424]
[puppet_vcsrepo.git] / .travis.yml
index ef2a36e..4e549bf 100644 (file)
@@ -1,33 +1,38 @@
+#This file is generated by ModuleSync, do not edit.
 ---
-branches:
-  only:
-    - master
+sudo: false
 language: ruby
-bundler_args: --without development
-script: "bundle exec rake spec SPEC_OPTS='--format documentation'"
-rvm:
-  - 1.8.7
-  - 1.9.3
-  - 2.0.0
-env:
-  matrix:
-  - PUPPET_GEM_VERSION="~> 2.7.0"
-  - PUPPET_GEM_VERSION="~> 3.3.0"
+cache: bundler
+script: "bundle exec rake validate lint spec"
 matrix:
   fast_finish: true
-  exclude:
+  include:
+  - rvm: 2.3.1
+    dist: trusty
+    env: PUPPET_INSTALL_TYPE=agent BEAKER_debug=true BEAKER_set=docker/ubuntu-14.04
+    script: bundle exec rake beaker
+    services: docker
+    sudo: required
+  - rvm: 2.3.1
+    dist: trusty
+    env: PUPPET_INSTALL_TYPE=agent BEAKER_debug=true BEAKER_set=docker/centos-7
+    script: bundle exec rake beaker
+    services: docker
+    sudo: required
+  - rvm: 2.3.1
+    bundler_args: --without system_tests
+    env: PUPPET_GEM_VERSION="~> 4.0"
+  - rvm: 2.1.9
+    bundler_args: --without system_tests
+    env: PUPPET_GEM_VERSION="~> 4.0"
+  - rvm: 2.1.5
+    bundler_args: --without system_tests
+    env: PUPPET_GEM_VERSION="~> 3.0" FUTURE_PARSER="yes"
+  - rvm: 2.1.5
+    bundler_args: --without system_tests
+    env: PUPPET_GEM_VERSION="~> 3.0"
   - rvm: 1.9.3
-    env: PUPPET_GEM_VERSION="~> 2.7.0"
-  - rvm: 2.0.0
-    env: PUPPET_GEM_VERSION="~> 2.7.0"
+    bundler_args: --without system_tests
+    env: PUPPET_GEM_VERSION="~> 3.0"
 notifications:
   email: false
-after_success:
-- git clone -q git://github.com/puppetlabs/ghpublisher.git .forge-release
-- .forge-release/publish
-before_install:
-- gem update --system 2.1.11
-- gem --version
-comments:
-- Temporary workaround for broken Rubygems on Travis
-