Remove compatability guarantees for SLES
[puppet_vcsrepo.git] / metadata.json
index 84551e5..29fb041 100644 (file)
@@ -1,24 +1,63 @@
 {
-    "name": "puppetlabs/vcsrepo",
-    "version": "0.1.2",
-    "summary": "Manage repositories from various version control systems",
-    "source": "git@github.com/puppetlabs/puppetlabs-vcsrepo.git",
-    "project_page": "http://github.com/puppetlabs/puppetlabs-vcsrepo",
+    "name": "puppetlabs-vcsrepo",
+    "version": "1.0.0",
+    "source": "https://github.com/puppetlabs/puppetlabs-vcsrepo",
     "author": "Puppet Labs",
-    "license": "Apache-2.0",
+    "license": "GPLv2",
+    "project_page": "https://github.com/puppetlabs/puppetlabs-vcsrepo",
+    "summary": "Puppet module providing a type to manage repositories from various version control systems",
     "operatingsystem_support": [
-        "RedHat",
-        "OpenSUSE",
-        "SLES",
-        "SLED",
-        "Debian",
-        "Ubuntu"
+      {
+        "operatingsystem": "RedHat",
+        "operatingsystemrelease": [
+          "5",
+          "6",
+          "7"
+        ]
+      },
+      {
+        "operatingsystem": "CentOS",
+        "operatingsystemrelease": [
+          "5",
+          "6",
+          "7"
+        ]
+      },
+      {
+        "operatingsystem": "OracleLinux",
+        "operatingsystemrelease": [
+          "5",
+          "6",
+          "7"
+        ]
+      },
+      {
+        "operatingsystem": "Scientific",
+        "operatingsystemrelease": [
+          "5",
+          "6",
+          "7"
+        ]
+      },
+      {
+        "operatingsystem": "Debian",
+        "operatingsystemrelease": [
+          "6",
+          "7"
+        ]
+      },
+      {
+        "operatingsystem": "Ubuntu",
+        "operatingsystemrelease": [
+          "10.04",
+          "12.04",
+          "14.04"
+        ]
+      }
     ],
-    "puppet_version": [
-        2.7,
-        3.0,
-        3.1,
-        3.2,
-        3.3
-    ]
+    "requirements": [
+      { "name": "pe", "version_requirement": ">= 3.2.0 < 3.4.0" },
+      { "name": "puppet", "version_requirement": "3.x" }
+    ],
+    "dependencies": []
 }