(MAINT) Update for modulesync_config 72d19f184
[puppet_vcsrepo.git] / Gemfile
diff --git a/Gemfile b/Gemfile
index 9b5b214..c7da908 100644 (file)
--- a/Gemfile
+++ b/Gemfile
@@ -13,14 +13,12 @@ def location_for(place, version = nil)
 end
 
 group :development, :unit_tests do
-  gem 'json',                      :require => false
-  gem 'metadata-json-lint',        :require => false
-  gem 'puppet_facts',              :require => false
-  gem 'puppetlabs_spec_helper',    :require => false
-  gem 'rspec-puppet', '>= 2.3.2',  :require => false
-  gem 'simplecov',                 :require => false
-  gem 'puppet-blacksmith',         :require => false
-  gem 'rest-client', '~> 1.8.0',   :require => false
+  gem 'metadata-json-lint',             :require => false
+  gem 'puppet_facts',                   :require => false
+  gem 'puppet-blacksmith', '>= 3.4.0',  :require => false
+  gem 'puppetlabs_spec_helper',         :require => false
+  gem 'rspec-puppet', '>= 2.3.2',       :require => false
+  gem 'simplecov',                      :require => false
 end
 group :system_tests do
   gem 'beaker-rspec',                  *location_for(ENV['BEAKER_RSPEC_VERSION'] || '>= 3.4')
@@ -31,10 +29,13 @@ group :system_tests do
   gem 'beaker-hostgenerator',          *location_for(ENV['BEAKER_HOSTGENERATOR_VERSION'])
 end
 
+# json_pure 2.0.2 added a requirement on ruby >= 2. We pin to json_pure 2.0.1
+# if using ruby 1.x
+gem 'json_pure', '<=2.0.1', :require => false if RUBY_VERSION =~ /^1\./
+
 gem 'facter', *location_for(ENV['FACTER_GEM_VERSION'])
 gem 'puppet', *location_for(ENV['PUPPET_GEM_VERSION'])
 
-
 if File.exists? "#{__FILE__}.local"
   eval(File.read("#{__FILE__}.local"), binding)
 end