Fix metadata.json to match checksum
[puppet_vcsrepo.git] / .travis.yml
index 5e3f744..c72d5e2 100644 (file)
@@ -1,34 +1,17 @@
 ---
-branches:
-  only:
-  - master
-notifications:
-  email: false
 language: ruby
-script:
-- 'bundle exec gem list'
-- 'bundle exec rake spec'
-after_success:
-- git clone -q git://github.com/puppetlabs/ghpublisher.git .forge-releng
-- .forge-releng/publish
-rvm:
-- 1.8.7
-- 1.9.3
-- 2.0.0
-env:
-  matrix:
-  - PUPPET_VERSION=2.6.18
-  - PUPPET_VERSION=2.7.22
-  - PUPPET_VERSION=3.2.1
-  global:
-  - PUBLISHER_LOGIN=puppetlabs
-  - secure: |-
-      ZiIkYd9+CdPzpwSjFPnVkCx1FIlipxpbdyD33q94h2Tj5zXjNb1GXizVy0NR
-      kVxGhU5Ld8y9z8DTqKRgCI1Yymg3H//OU++PKLOQj/X5juWVR4URBNPeBOzu
-      IJBDl1MADKA4i1+jAZPpz4mTvTtKS4pWKErgCSmhSfsY1hs7n6c=
+bundler_args: --without development
+script: "bundle exec rake spec SPEC_OPTS='--format documentation'"
 matrix:
-  exclude:
+  fast_finish: true
+  include:
+  - rvm: 1.8.7
+    env: PUPPET_GEM_VERSION="~> 2.7.0" FACTER_GEM_VERSION="~> 1.6.0"
+  - rvm: 1.8.7
+    env: PUPPET_GEM_VERSION="~> 2.7.0" FACTER_GEM_VERSION="~> 1.7.0"
   - rvm: 1.9.3
-    env: PUPPET_VERSION=2.6.18
+    env: PUPPET_GEM_VERSION="~> 3.0"
   - rvm: 2.0.0
-    env: PUPPET_VERSION=2.6.18
+    env: PUPPET_GEM_VERSION="~> 3.0"
+notifications:
+  email: false