(MAINT) Update for modulesync_config 72d19f184
[puppet_vcsrepo.git] / Gemfile
1 #This file is generated by ModuleSync, do not edit.
2
3 source ENV['GEM_SOURCE'] || "https://rubygems.org"
4
5 def location_for(place, version = nil)
6   if place =~ /^(git[:@][^#]*)#(.*)/
7     [version, { :git => $1, :branch => $2, :require => false}].compact
8   elsif place =~ /^file:\/\/(.*)/
9     ['>= 0', { :path => File.expand_path($1), :require => false}]
10   else
11     [place, version, { :require => false}].compact
12   end
13 end
14
15 group :development, :unit_tests do
16   gem 'metadata-json-lint',             :require => false
17   gem 'puppet_facts',                   :require => false
18   gem 'puppet-blacksmith', '>= 3.4.0',  :require => false
19   gem 'puppetlabs_spec_helper',         :require => false
20   gem 'rspec-puppet', '>= 2.3.2',       :require => false
21   gem 'simplecov',                      :require => false
22 end
23 group :system_tests do
24   gem 'beaker-rspec',                  *location_for(ENV['BEAKER_RSPEC_VERSION'] || '>= 3.4')
25   gem 'beaker',                        *location_for(ENV['BEAKER_VERSION'])
26   gem 'serverspec',                    :require => false
27   gem 'beaker-puppet_install_helper',  :require => false
28   gem 'master_manipulator',            :require => false
29   gem 'beaker-hostgenerator',          *location_for(ENV['BEAKER_HOSTGENERATOR_VERSION'])
30 end
31
32 # json_pure 2.0.2 added a requirement on ruby >= 2. We pin to json_pure 2.0.1
33 # if using ruby 1.x
34 gem 'json_pure', '<=2.0.1', :require => false if RUBY_VERSION =~ /^1\./
35
36 gem 'facter', *location_for(ENV['FACTER_GEM_VERSION'])
37 gem 'puppet', *location_for(ENV['PUPPET_GEM_VERSION'])
38
39 if File.exists? "#{__FILE__}.local"
40   eval(File.read("#{__FILE__}.local"), binding)
41 end