Merge pull request #283 from DavidS/fm-4049-update-msync
[puppet_vcsrepo.git] / .travis.yml
1 ---
2 sudo: false
3 language: ruby
4 cache: bundler
5 bundler_args: --without system_tests
6 script: "bundle exec rake validate lint spec"
7 matrix:
8   fast_finish: true
9   include:
10   - rvm: 2.1.6
11     env: PUPPET_GEM_VERSION="~> 4.0" STRICT_VARIABLES="yes"
12   - rvm: 2.1.5
13     env: PUPPET_GEM_VERSION="~> 3.0" FUTURE_PARSER="yes"
14   - rvm: 2.1.5
15     env: PUPPET_GEM_VERSION="~> 3.0"
16   - rvm: 1.9.3
17     env: PUPPET_GEM_VERSION="~> 3.0"
18 notifications:
19   email: false