cc77f38cfadb685e739d70ee4e25a8b6a473888b
[puppet_vcsrepo.git] / Gemfile
1 source ENV['GEM_SOURCE'] || "https://rubygems.org"
2
3 group :development, :unit_tests do
4   gem 'rspec-core', '3.1.7',     :require => false
5   gem 'puppetlabs_spec_helper',  :require => false
6   gem 'simplecov',               :require => false
7   gem 'puppet_facts',            :require => false
8   gem 'json',                    :require => false
9 end
10
11 group :system_tests do
12   gem 'beaker-rspec',  :require => false
13   gem 'serverspec',    :require => false
14 end
15
16 if facterversion = ENV['FACTER_GEM_VERSION']
17   gem 'facter', facterversion, :require => false
18 else
19   gem 'facter', :require => false
20 end
21
22 if puppetversion = ENV['PUPPET_GEM_VERSION']
23   gem 'puppet', puppetversion, :require => false
24 else
25   gem 'puppet', :require => false
26 end
27
28 # vim:ft=ruby