Merge pull request #171 from p4paul/master
[puppet_vcsrepo.git] / .travis.yml
1 ---
2 language: ruby
3 bundler_args: --without development
4 script: "bundle exec rake spec SPEC_OPTS='--format documentation'"
5 matrix:
6   fast_finish: true
7   include:
8   - rvm: 1.8.7
9     env: PUPPET_GEM_VERSION="~> 2.7.0" FACTER_GEM_VERSION="~> 1.6.0"
10   - rvm: 1.8.7
11     env: PUPPET_GEM_VERSION="~> 2.7.0" FACTER_GEM_VERSION="~> 1.7.0"
12   - rvm: 1.9.3
13     env: PUPPET_GEM_VERSION="~> 3.0"
14   - rvm: 2.0.0
15     env: PUPPET_GEM_VERSION="~> 3.0"
16 notifications:
17   email: false