Update modulesync_config [a3fe424]
[puppet_vcsrepo.git] / Gemfile
1 #This file is generated by ModuleSync, do not edit.
2
3 source ENV['GEM_SOURCE'] || "https://rubygems.org"
4
5 def location_from_env(env, default_location = [])
6   if location = ENV[env]
7     if location =~ /^((?:git|https?)[:@][^#]*)#(.*)/
8       [{ :git => $1, :branch => $2, :require => false }]
9     elsif location =~ /^file:\/\/(.*)/
10       ['>= 0', { :path => File.expand_path($1), :require => false }]
11     else
12       [location, { :require => false }]
13     end
14   else
15     default_location
16   end
17 end
18
19 group :development, :unit_tests do
20   gem 'metadata-json-lint'
21   gem 'puppet_facts'
22   gem 'puppet-blacksmith', '>= 3.4.0'
23   gem 'puppetlabs_spec_helper', '>= 1.2.1'
24   gem 'rspec-puppet', '>= 2.3.2'
25   gem 'rspec-puppet-facts'
26   gem 'simplecov'
27   gem 'parallel_tests'
28   gem 'rubocop', '0.41.2' if RUBY_VERSION < '2.0.0'
29   gem 'rubocop' if RUBY_VERSION >= '2.0.0'
30   gem 'rubocop-rspec', '~> 1.6' if RUBY_VERSION >= '2.3.0'
31   gem 'json_pure', '<= 2.0.1' if RUBY_VERSION < '2.0.0'
32 end
33 group :system_tests do
34   gem 'beaker', *location_from_env('BEAKER_VERSION', []) if RUBY_VERSION >= '2.3.0'
35   gem 'beaker', *location_from_env('BEAKER_VERSION', ['< 3']) if RUBY_VERSION < '2.3.0'
36   gem 'beaker-rspec', *location_from_env('BEAKER_RSPEC_VERSION', ['>= 3.4'])
37   gem 'serverspec'
38   gem 'beaker-puppet_install_helper'
39   gem 'master_manipulator'
40   gem 'beaker-hostgenerator', *location_from_env('BEAKER_HOSTGENERATOR_VERSION', [])
41 end
42
43 gem 'facter', *location_from_env('FACTER_GEM_VERSION')
44 gem 'puppet', *location_from_env('PUPPET_GEM_VERSION')
45
46 if File.exists? "#{__FILE__}.local"
47   eval(File.read("#{__FILE__}.local"), binding)
48 end