Fix issue with puppet_module_install, removed and using updated method from beaker...
[puppet_vcsrepo.git] / metadata.json
1 {
2   "name": "puppetlabs-vcsrepo",
3   "version": "1.1.0",
4   "author": "Puppet Labs",
5   "summary": "Puppet module providing a type to manage repositories from various version control systems",
6   "license": "GPLv2",
7   "source": "https://github.com/puppetlabs/puppetlabs-vcsrepo",
8   "project_page": "https://github.com/puppetlabs/puppetlabs-vcsrepo",
9   "issues_url": "https://github.com/puppetlabs/puppetlabs-vcsrepo/issues",
10   "operatingsystem_support": [
11     {
12       "operatingsystem": "RedHat",
13       "operatingsystemrelease": [
14         "5",
15         "6",
16         "7"
17       ]
18     },
19     {
20       "operatingsystem": "CentOS",
21       "operatingsystemrelease": [
22         "5",
23         "6",
24         "7"
25       ]
26     },
27     {
28       "operatingsystem": "OracleLinux",
29       "operatingsystemrelease": [
30         "5",
31         "6",
32         "7"
33       ]
34     },
35     {
36       "operatingsystem": "Scientific",
37       "operatingsystemrelease": [
38         "5",
39         "6",
40         "7"
41       ]
42     },
43     {
44       "operatingsystem": "SLES",
45       "operatingsystemrelease": [
46         "11 SP1"
47       ]
48     },
49     {
50       "operatingsystem": "Debian",
51       "operatingsystemrelease": [
52         "6",
53         "7"
54       ]
55     },
56     {
57       "operatingsystem": "Ubuntu",
58       "operatingsystemrelease": [
59         "10.04",
60         "12.04",
61         "14.04"
62       ]
63     }
64   ],
65   "requirements": [
66     {
67       "name": "pe",
68       "version_requirement": ">= 3.2.0 < 3.4.0"
69     },
70     {
71       "name": "puppet",
72       "version_requirement": "3.x"
73     }
74   ],
75   "dependencies": [
76   
77   ]
78 }