Merge branch '1.0.x'
[puppet_vcsrepo.git] / .travis.yml
1 ---
2 branches:
3   only:
4     - master
5 language: ruby
6 bundler_args: --without development
7 script: "bundle exec rake spec SPEC_OPTS='--format documentation'"
8 rvm:
9   - 1.8.7
10   - 1.9.3
11   - 2.0.0
12 env:
13   matrix:
14   - PUPPET_GEM_VERSION="~> 2.7.0"
15   - PUPPET_GEM_VERSION="~> 3.3.0"
16 matrix:
17   fast_finish: true
18   exclude:
19   - rvm: 1.9.3
20     env: PUPPET_GEM_VERSION="~> 2.7.0"
21   - rvm: 2.0.0
22     env: PUPPET_GEM_VERSION="~> 2.7.0"
23 notifications:
24   email: false
25 after_success:
26 - git clone -q git://github.com/puppetlabs/ghpublisher.git .forge-release
27 - .forge-release/publish
28 before_install:
29 - gem update --system 2.1.11
30 - gem --version
31 comments:
32 - Temporary workaround for broken Rubygems on Travis
33