Merge pull request #242 from BillWeiss/bump-ssl-expiry
[puppet_vcsrepo.git] / .travis.yml
1 ---
2 sudo: false
3 language: ruby
4 bundler_args: --without system_tests
5 script: "bundle exec rake spec SPEC_OPTS='--format documentation'"
6 matrix:
7   fast_finish: true
8   include:
9   - rvm: 1.8.7
10     env: PUPPET_GEM_VERSION="~> 3.0"
11   - rvm: 1.9.3
12     env: PUPPET_GEM_VERSION="~> 3.0"
13   - rvm: 2.1.5
14     env: PUPPET_GEM_VERSION="~> 3.0"
15   - rvm: 2.1.5
16     env: PUPPET_GEM_VERSION="~> 3.0" FUTURE_PARSER="yes"
17   - rvm: 2.1.6
18     env: PUPPET_GEM_VERSION="~> 4.0" STRICT_VARIABLES="yes"
19   - rvm: 1.8.7
20     env: PUPPET_GEM_VERSION="~> 2.7.0" FACTER_GEM_VERSION="~> 1.6.0"
21   - rvm: 1.8.7
22     env: PUPPET_GEM_VERSION="~> 2.7.0" FACTER_GEM_VERSION="~> 1.7.0"
23   allow_failures:
24     - rvm: 2.1.6
25       env: PUPPET_GEM_VERSION="~> 4.0" STRICT_VARIABLES="yes"
26 notifications:
27   email: false