(FM-4049) Update to current msync configs [2c99161]
[puppet_vcsrepo.git] / Gemfile
1 source ENV['GEM_SOURCE'] || "https://rubygems.org"
2
3 def location_for(place, fake_version = nil)
4   if place =~ /^(git[:@][^#]*)#(.*)/
5     [fake_version, { :git => $1, :branch => $2, :require => false }].compact
6   elsif place =~ /^file:\/\/(.*)/
7     ['>= 0', { :path => File.expand_path($1), :require => false }]
8   else
9     [place, { :require => false }]
10   end
11 end
12
13 group :development, :unit_tests do
14   gem 'json',                      :require => false
15   gem 'metadata-json-lint',        :require => false
16   gem 'puppet_facts',              :require => false
17   gem 'puppet-blacksmith',         :require => false
18   gem 'puppetlabs_spec_helper',    :require => false
19   gem 'rspec-puppet', '>= 2.3.2',  :require => false
20   gem 'simplecov',                 :require => false
21 end
22 group :system_tests do
23   gem 'beaker-puppet_install_helper',  :require => false
24   if beaker_version = ENV['BEAKER_VERSION']
25     gem 'beaker', *location_for(beaker_version)
26   end
27   if beaker_rspec_version = ENV['BEAKER_RSPEC_VERSION']
28     gem 'beaker-rspec', *location_for(beaker_rspec_version)
29   else
30     gem 'beaker-rspec',  :require => false
31   end
32   gem 'master_manipulator',            :require => false
33   gem 'serverspec',                    :require => false
34 end
35
36 if facterversion = ENV['FACTER_GEM_VERSION']
37   gem 'facter', facterversion, :require => false
38 else
39   gem 'facter', :require => false
40 end
41
42 if puppetversion = ENV['PUPPET_GEM_VERSION']
43   gem 'puppet', puppetversion, :require => false
44 else
45   gem 'puppet', :require => false
46 end
47
48 # vim:ft=ruby