Update Gemfile for .travis.yml defaults
[puppet_vcsrepo.git] / metadata.json
1 {
2     "name": "puppetlabs-vcsrepo",
3     "version": "1.0.1",
4     "source": "https://github.com/puppetlabs/puppetlabs-vcsrepo",
5     "author": "Puppet Labs",
6     "license": "GPLv2",
7     "project_page": "https://github.com/puppetlabs/puppetlabs-vcsrepo",
8     "summary": "Puppet module providing a type to manage repositories from various version control systems",
9     "operatingsystem_support": [
10       {
11         "operatingsystem": "RedHat",
12         "operatingsystemrelease": [
13           "5",
14           "6",
15           "7"
16         ]
17       },
18       {
19         "operatingsystem": "CentOS",
20         "operatingsystemrelease": [
21           "5",
22           "6",
23           "7"
24         ]
25       },
26       {
27         "operatingsystem": "OracleLinux",
28         "operatingsystemrelease": [
29           "5",
30           "6",
31           "7"
32         ]
33       },
34       {
35         "operatingsystem": "Scientific",
36         "operatingsystemrelease": [
37           "5",
38           "6",
39           "7"
40         ]
41       },
42       {
43         "operatingsystem": "Debian",
44         "operatingsystemrelease": [
45           "6",
46           "7"
47         ]
48       },
49       {
50         "operatingsystem": "Ubuntu",
51         "operatingsystemrelease": [
52           "10.04",
53           "12.04",
54           "14.04"
55         ]
56       }
57     ],
58     "requirements": [
59       { "name": "pe", "version_requirement": ">= 3.2.0 < 3.4.0" },
60       { "name": "puppet", "version_requirement": "3.x" }
61     ],
62     "dependencies": []
63 }