Disable simplecov on Ruby 1.8.7
[puppet_vcsrepo.git] / spec / spec_helper.rb
1 require 'puppetlabs_spec_helper/module_spec_helper'
2 require 'support/filesystem_helpers'
3 require 'support/fixture_helpers'
4
5 # SimpleCov does not run on Ruby 1.8.7
6 unless RUBY_VERSION.to_f < 1.9
7   require 'simplecov'
8   SimpleCov.start do
9     add_filter '/spec/'
10   end
11 end
12
13 RSpec.configure do |c|
14   c.include FilesystemHelpers
15   c.include FixtureHelpers
16 end