Merge remote-tracking branch 'camptocamp/master'
[puppet_systemd.git] / Gemfile
1 source ENV['GEM_SOURCE'] || "https://rubygems.org"
2
3 group :development, :unit_tests do
4   gem 'rake',                                              :require => false
5   gem 'rspec',                                             :require => false
6   gem 'rspec-puppet',                                      :require => false
7   gem 'puppetlabs_spec_helper',                            :require => false
8   gem 'metadata-json-lint',                                :require => false
9   gem 'puppet-lint',                                       :require => false
10   gem 'puppet-lint-unquoted_string-check',                 :require => false
11   gem 'puppet-lint-empty_string-check',                    :require => false
12   gem 'puppet-lint-spaceship_operator_without_tag-check',  :require => false
13   gem 'puppet-lint-absolute_classname-check',              :require => false
14   gem 'puppet-lint-undef_in_function-check',               :require => false
15   gem 'puppet-lint-leading_zero-check',                    :require => false
16   gem 'puppet-lint-trailing_comma-check',                  :require => false
17   gem 'puppet-lint-file_ensure-check',                     :require => false
18   gem 'puppet-lint-version_comparison-check',              :require => false
19   gem 'puppet-lint-file_source_rights-check',              :require => false
20   gem 'puppet-lint-alias-check',                           :require => false
21   gem 'rspec-puppet-facts',                                :require => false
22   gem 'ruby-augeas',                                       :require => false
23   gem 'puppet-blacksmith',                                 :require => false if RUBY_VERSION !~ /^1\./
24   gem 'json_pure', '< 2.0.2',                              :require => false
25 end
26
27 group :system_tests do
28   gem 'beaker',               :require => false
29   gem 'beaker-rspec', '> 5',  :require => false
30   gem 'beaker_spec_helper',   :require => false
31   gem 'serverspec',           :require => false
32   gem 'specinfra',            :require => false
33 end
34
35 if facterversion = ENV['FACTER_GEM_VERSION']
36   gem 'facter', facterversion, :require => false
37 else
38   gem 'facter', :require => false
39 end
40
41 if puppetversion = ENV['PUPPET_GEM_VERSION']
42   gem 'puppet', puppetversion, :require => false
43 else
44   gem 'puppet', :require => false
45 end
46
47 # vim:ft=ruby