Merge remote-tracking branch 'origin/master' into leap_master
[puppet_stdlib.git] / metadata.json
1 {
2   "name": "puppetlabs-stdlib",
3   "version": "4.20.0",
4   "author": "puppetlabs",
5   "summary": "Standard library of resources for Puppet modules.",
6   "license": "Apache-2.0",
7   "source": "https://github.com/puppetlabs/puppetlabs-stdlib",
8   "project_page": "https://github.com/puppetlabs/puppetlabs-stdlib",
9   "issues_url": "https://tickets.puppetlabs.com/browse/MODULES",
10   "operatingsystem_support": [
11     {
12       "operatingsystem": "RedHat",
13       "operatingsystemrelease": [
14         "4",
15         "5",
16         "6",
17         "7"
18       ]
19     },
20     {
21       "operatingsystem": "CentOS",
22       "operatingsystemrelease": [
23         "4",
24         "5",
25         "6",
26         "7"
27       ]
28     },
29     {
30       "operatingsystem": "OracleLinux",
31       "operatingsystemrelease": [
32         "4",
33         "5",
34         "6",
35         "7"
36       ]
37     },
38     {
39       "operatingsystem": "Scientific",
40       "operatingsystemrelease": [
41         "4",
42         "5",
43         "6",
44         "7"
45       ]
46     },
47     {
48       "operatingsystem": "SLES",
49       "operatingsystemrelease": [
50         "10 SP4",
51         "11 SP1",
52         "12"
53       ]
54     },
55     {
56       "operatingsystem": "Debian",
57       "operatingsystemrelease": [
58         "7",
59         "8"
60       ]
61     },
62     {
63       "operatingsystem": "Ubuntu",
64       "operatingsystemrelease": [
65         "14.04",
66         "16.04"
67       ]
68     },
69     {
70       "operatingsystem": "Solaris",
71       "operatingsystemrelease": [
72         "10",
73         "11"
74       ]
75     },
76     {
77       "operatingsystem": "Windows",
78       "operatingsystemrelease": [
79         "Server 2003",
80         "Server 2003 R2",
81         "Server 2008",
82         "Server 2008 R2",
83         "Server 2012",
84         "Server 2012 R2",
85         "7",
86         "8"
87       ]
88     },
89     {
90       "operatingsystem": "AIX",
91       "operatingsystemrelease": [
92         "5.3",
93         "6.1",
94         "7.1"
95       ]
96     }
97   ],
98   "requirements": [
99     {
100       "name": "puppet",
101       "version_requirement": ">=2.7.20 < 6.0.0"
102     }
103   ],
104   "description": "Standard Library for Puppet Modules",
105   "dependencies": [
106
107   ]
108 }