Merge remote-tracking branch 'origin/master' into leap_master
[puppet_stdlib.git] / appveyor.yml
1 version: 1.1.x.{build}
2 skip_commits:
3   message: /^\(?doc\)?.*/
4 clone_depth: 10
5 init:
6 - SET
7 - 'mkdir C:\ProgramData\PuppetLabs\code && exit 0'
8 - 'mkdir C:\ProgramData\PuppetLabs\facter && exit 0'
9 - 'mkdir C:\ProgramData\PuppetLabs\hiera && exit 0'
10 - 'mkdir C:\ProgramData\PuppetLabs\puppet\var && exit 0'
11 environment:
12   matrix:
13   - PUPPET_GEM_VERSION: ~> 4.0
14     RUBY_VER: 21
15   - PUPPET_GEM_VERSION: ~> 4.0
16     RUBY_VER: 21-x64
17   - PUPPET_GEM_VERSION: ~> 5.0
18     RUBY_VER: 24
19   - PUPPET_GEM_VERSION: ~> 5.0
20     RUBY_VER: 24-x64
21   - PUPPET_GEM_VERSION: 4.7.1
22     RUBY_VER: 21-x64
23 matrix:
24   fast_finish: true
25 install:
26 - SET PATH=C:\Ruby%RUBY_VER%\bin;%PATH%
27 - ps: |
28     # AppVeyor appears to have OpenSSL headers available already
29     # which msys2 would normally install with:
30     # pacman -S mingw-w64-x86_64-openssl --noconfirm
31     #
32     if ( $(ruby --version) -match "^ruby\s+2\.4" ) {
33       Write-Output "Building OpenSSL gem ~> 2.0.4 to fix Ruby 2.4 / AppVeyor issue"
34       gem install openssl --version '~> 2.0.4' --no-ri --no-rdoc
35     }
36
37     gem list openssl
38     ruby -ropenssl -e 'puts \"OpenSSL Version - #{OpenSSL::OPENSSL_VERSION}\"; puts \"OpenSSL Library Version - #{OpenSSL::OPENSSL_LIBRARY_VERSION}\"'
39 - bundle install --jobs 4 --retry 2 --without system_tests
40 - type Gemfile.lock
41 build: off
42 test_script:
43 - bundle exec puppet -V
44 - ruby -v
45 - bundle exec rake spec SPEC_OPTS='--format documentation'
46 notifications:
47 - provider: Email
48   to:
49   - nobody@nowhere.com
50   on_build_success: false
51   on_build_failure: false
52   on_build_status_changed: false