we need rubygems as well there