add some rubygems, add dep to tlsmail for mail for ruby 1.8.6
authormh <mh@immerda.ch>
Tue, 27 Apr 2010 00:02:14 +0000 (02:02 +0200)
committermh <mh@immerda.ch>
Tue, 27 Apr 2010 00:02:14 +0000 (02:02 +0200)
manifests/backports.pp [new file with mode: 0644]
manifests/mail.pp
manifests/tlsmail.pp [new file with mode: 0644]

diff --git a/manifests/backports.pp b/manifests/backports.pp
new file mode 100644 (file)
index 0000000..4290e34
--- /dev/null
@@ -0,0 +1,7 @@
+class rubygems::backports {
+  require rubygems::devel
+  package{'backports':
+    ensure => present,
+    provider => gem,
+  }
+}
index a7c5f1a..4afa0c7 100644 (file)
@@ -4,4 +4,8 @@ class rubygems::mail {
     ensure => present,
     provider => gem,
   }
+
+  if $rubyversion == '1.8.6' {
+    require rubygems::tlsmail
+  }
 }
diff --git a/manifests/tlsmail.pp b/manifests/tlsmail.pp
new file mode 100644 (file)
index 0000000..71aa615
--- /dev/null
@@ -0,0 +1,7 @@
+class rubygems::tlsmail {
+  require rubygems::devel
+  package{'tlsmail':
+    ensure => present,
+    provider => gem,
+  }
+}