added gpgme, highline and tmail gem
authormh <mh@immerda.ch>
Thu, 14 May 2009 18:06:58 +0000 (20:06 +0200)
committermh <mh@immerda.ch>
Thu, 14 May 2009 18:06:58 +0000 (20:06 +0200)
manifests/gpgme.pp [new file with mode: 0644]
manifests/highline.pp [new file with mode: 0644]
manifests/tmail.pp [new file with mode: 0644]

diff --git a/manifests/gpgme.pp b/manifests/gpgme.pp
new file mode 100644 (file)
index 0000000..952c0d6
--- /dev/null
@@ -0,0 +1,10 @@
+class rubygems::gpgme{
+  include rubygems
+  include gpg::gpgme::devel
+
+  package{'ruby-gpgme':
+    ensure => present,
+    provider => gem,
+    require => Package['rubygems'],
+  }
+}
diff --git a/manifests/highline.pp b/manifests/highline.pp
new file mode 100644 (file)
index 0000000..0ef0771
--- /dev/null
@@ -0,0 +1,7 @@
+class rubygems::highline {
+  package{'highline':
+    ensure => present,
+    provider => gem, 
+    require => Package['rubygems'],
+  }
+}
diff --git a/manifests/tmail.pp b/manifests/tmail.pp
new file mode 100644 (file)
index 0000000..2510c03
--- /dev/null
@@ -0,0 +1,7 @@
+class rubygems::tmail {
+  package{'tmail':
+    ensure => present,
+    provider => gem,
+    require => Package['rubygems'],
+  }
+}