Update versioncmp for modern puppet master
authorkwadronaut <kwadronaut@leap.se>
Mon, 22 Oct 2018 08:52:47 +0000 (10:52 +0200)
committerkwadronaut <kwadronaut@leap.se>
Mon, 22 Oct 2018 08:52:47 +0000 (10:52 +0200)
manifests/init.pp

index bca40b9..baded5e 100644 (file)
@@ -16,7 +16,7 @@
 # manage rubygems basics
 class rubygems {
   # from debian 8 on this is not anymore needed as it's part of the ruby pkg
-  if ($::operatingsystem != 'Debian') or (versioncmp($::operatingsystemrelease,'8') < 0) {
+  if ($::operatingsystem != 'Debian') or (versioncmp("${::operatingsystemmajrelease}",'8') < 0) {
     package{'rubygems':
       ensure => installed,
     }