no need to install rubygems anymore
[puppet_rubygems.git] / manifests / init.pp
index 678bd54..0585994 100644 (file)
 #
 
 class rubygems {
 #
 
 class rubygems {
-  package{'rubygems':
-    ensure => installed,
+  # from debian 8 on this is not anymore needed
+  if ($::operatingsystem != 'Debian') or (versioncmp($::operatingsystemmajrelease,'8') < 0) {
+    package{'rubygems':
+      ensure => installed,
+    }
   }
 }
   }
 }