from jessie on, use ruby-gpgme not libgpgme-ruby (closes #8270)
[puppet_rubygems.git] / manifests / gpgme.pp
index e9b04a9..483fdc9 100644 (file)
@@ -8,12 +8,17 @@ class rubygems::gpgme{
           $provider    = 'gem'
           $packagename = 'ruby-gpgme'
           }
-        default:  {
+        'wheezy':  {
           # don't need to install gpgme as gem, debian package works
           # fine with the gpg module
           $provider    = 'apt'
           $packagename = 'libgpgme-ruby'
         }
+        default:  {
+          # from jessie on this package
+          $provider    = 'apt'
+          $packagename = 'ruby-gpgme'
+        }
       }
     }
     default: {