from centos 6 on this can be installed that way
[puppet_rubygems.git] / manifests / postgres.pp
index bcfc511..00f09be 100644 (file)
@@ -1,4 +1,10 @@
 class rubygems::postgres {
+  if $operatingsystem == 'CentOS' and $lsbmajdistrelease > 5 {
+    package{'rubygem-pg':
+      ensure => installed,
+    }
+  } else {
     require postgres::devel
     rubygems::gem{'ruby-pg':}
+  }
 }