make it el7 ready
[puppet_rubygems.git] / manifests / xmlsimple.pp
1 # xml simple lib
2 class rubygems::xmlsimple {
3   package{'rubygem-xml-simple':
4     ensure => present,
5   }
6   case $operatingsystem {
7     debian,ubuntu: {
8       Package['rubygem-xml-simple']{
9         name => 'libxml-simple-ruby'
10       }
11     }
12   }
13   if $::operatingsystem == 'CentOS' and $::operatingsystemmajrelease > 6 {
14     # not yet packaged
15     Package['rubygem-xml-simple']{
16       name     => 'xml-simple',
17       provider => gem,
18     }
19   }
20 }