added requiresgcc parameter
[puppet_rubygems.git] / manifests / package.pp
1 define rubygems::package(
2     $ensure = 'present', 
3     $requiresgcc = false
4 ) {
5     if $requiresgcc {
6         require gcc
7     }
8
9     package{$name:
10         provider => gem,
11         ensure => $ensure,
12         require => Package['rubygems'],
13     }
14 }