Fix file mode type in module_file
[puppet_common.git] / Gemfile
1 source "https://rubygems.org"
2
3 group :development, :unit_tests do
4   gem "rake"
5   gem "rspec-puppet", "~> 2.1", :require => false
6   gem "rspec-core", "3.1.7",    :require => false
7   gem "puppetlabs_spec_helper"
8   gem "metadata-json-lint"
9   gem "rspec-puppet-facts"
10   gem "mocha"
11 end
12
13 group :system_tests do
14   gem 'beaker'
15   gem 'beaker-rspec'
16   gem 'beaker_spec_helper'
17   gem 'serverspec'
18 end
19
20 gem "puppet", ENV['PUPPET_VERSION'] || ENV['GEM_PUPPET_VERSION'] || ENV['PUPPET_GEM_VERSION'] || '~> 3.7.0'
21 gem "facter", ENV['FACTER_VERSION'] || ENV['GEM_FACTER_VERSION'] || ENV['FACTER_GEM_VERSION'] || '~> 2.2.0'
22