Age | Commit message (Collapse) | Author |
|
Before, including apt::unattended_upgrades on a host without
the unattended-upgrades package would fail on the first run,
because the module tries to install the package before apt is
finally configured.
This commit does:
- introduce the option $refresh_apt for apt::apt_conf
(Defaults to true). Can be used to not trigger Exec['refresh_apt']
- install the unattended-upgrades package after a final
Exec['refresh_apt']. To not run into a loop, it calls
Apt_conf['50unattended-upgrades'] with the option
refresh_apt => false, which is also not needed for the configuration
|
|
Signed-off-by: Gabriel Filion <lelutin@gmail.com>
+ more linting by intrigeri.
Conflicts:
manifests/apticron.pp
manifests/cron/dist_upgrade.pp
manifests/cron/download.pp
manifests/dist_upgrade/initiator.pp
manifests/init.pp
manifests/listchanges.pp
manifests/preferences.pp
manifests/preseeded_package.pp
manifests/proxy_client.pp
manifests/unattended_upgrades.pp
manifests/update.pp
|
|
sources_list doesn't currently force puppet to run 'apt-get update'
after creating/modifying/removing files in sources.list.d.
Signed-off-by: Gabriel Filion <lelutin@gmail.com>
|
|
The .d directories are only managed by the main 'apt' class. However,
both 'sources_list' and 'apt_conf' defines depend on those directories.
So in practice, the defines have an implicit need for those directories
to be somehow managed.
Let's turn this into an explicit relation, and include the directories
in the defines.
This makes it possible to use both defines without having to include the
main 'apt' class. (maybe when using puppet apply?)
Signed-off-by: Gabriel Filion <lelutin@gmail.com>
|
|
|
|
|
|
Current mode (600) makes it impossible to use apt-cache to search for
package names and info, since it tries to read all configuration files
in /etc/apt/apt.conf.d before executing.
Change configuration file mode to 644 so that search tasks can be made
without root priviledge.
|
|
remove the use of _snippet in names (except for preferences_snippet) so
that they represent directly a resource name.
rename custom_sources_template to sources_list.
modify sources_list to make it more flexible (gives the opportunity to
provide sources or content). this changes its behaviour in that the name
is now the name of the file in sources.list.d
rename proxy-client to proxy_client to use the same standard for its
name as the other classes.
Signed-off-by: Gabriel Filion <lelutin@gmail.com>
|