Add missing requires to chromedriver module
[pixelated-user-agent.git] / Vagrantfile
1 # -*- mode: ruby -*-
2 # vi: set ft=ruby :
3
4 VAGRANTFILE_API_VERSION = "2"
5
6 Vagrant.configure(VAGRANTFILE_API_VERSION) do |config|
7   config.vm.box = "LEAP/jessie"
8
9   config.vm.define "source" do |source|
10     source.vm.provision "puppet" do |puppet|
11       puppet.manifests_path = "provisioning/manifests"
12       puppet.module_path    = "provisioning/modules"
13       puppet.manifest_file  = "source.pp"
14     end
15   end
16
17   if /mswin|mingw/ =~ RUBY_PLATFORM
18     config.vm.synced_folder ".", "/vagrant", type: "rsync", rsync__exclude: ".git/"
19   end
20
21   config.vm.provider "libvirt" do |v, override|
22     v.memory = 2048
23     override.vm.network :forwarded_port, guest: 3333, guest_ip: '127.0.0.1', host: 3333
24   end
25
26   config.vm.provider "virtualbox" do |v, override|
27     v.memory = 2048
28     override.vm.network :forwarded_port, guest: 3333, host: 3333 # do NOT add host_ip in this line. It is not necessary
29     override.vm.network :forwarded_port, guest: 8089, host: 8089
30   end
31 end