summaryrefslogtreecommitdiff
path: root/test/default/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/default/Makefile.am')
-rw-r--r--test/default/Makefile.am44
1 files changed, 27 insertions, 17 deletions
diff --git a/test/default/Makefile.am b/test/default/Makefile.am
index 8ad3c1f..11d76e0 100644
--- a/test/default/Makefile.am
+++ b/test/default/Makefile.am
@@ -23,6 +23,7 @@ EXTRA_DIST = \
core4.exp \
core5.exp \
core6.exp \
+ ed25519_convert.exp \
generichash.exp \
generichash2.exp \
generichash3.exp \
@@ -34,10 +35,12 @@ EXTRA_DIST = \
onetimeauth7.exp \
pwhash.exp \
pwhash_scrypt_ll.exp \
+ randombytes.exp \
scalarmult.exp \
scalarmult2.exp \
scalarmult5.exp \
scalarmult6.exp \
+ scalarmult7.exp \
secretbox.exp \
secretbox2.exp \
secretbox7.exp \
@@ -48,13 +51,13 @@ EXTRA_DIST = \
sign.exp \
sodium_core.exp \
sodium_utils.exp \
+ sodium_utils2.exp \
+ sodium_utils3.exp \
sodium_version.exp \
stream.exp \
stream2.exp \
stream3.exp \
stream4.exp \
- stream5.exp \
- stream6.exp \
verify1.exp
DISTCLEANFILES = \
@@ -79,6 +82,7 @@ DISTCLEANFILES = \
core4.res \
core5.res \
core6.res \
+ ed25519_convert.res \
generichash.res \
generichash2.res \
generichash3.res \
@@ -90,10 +94,12 @@ DISTCLEANFILES = \
onetimeauth7.res \
pwhash.res \
pwhash_scrypt_ll.res \
+ randombytes.res \
scalarmult.res \
scalarmult2.res \
scalarmult5.res \
scalarmult6.res \
+ scalarmult7.res \
secretbox.res \
secretbox2.res \
secretbox7.res \
@@ -104,13 +110,13 @@ DISTCLEANFILES = \
sign.res \
sodium_core.res \
sodium_utils.res \
+ sodium_utils2.res \
+ sodium_utils3.res \
sodium_version.res \
stream.res \
stream2.res \
stream3.res \
stream4.res \
- stream5.res \
- stream6.res \
verify1.res
AM_CPPFLAGS = \
@@ -143,6 +149,7 @@ TESTS_TARGETS = \
core4 \
core5 \
core6 \
+ ed25519_convert \
generichash \
generichash2 \
generichash3 \
@@ -158,6 +165,7 @@ TESTS_TARGETS = \
scalarmult2 \
scalarmult5 \
scalarmult6 \
+ scalarmult7 \
secretbox \
secretbox2 \
secretbox7 \
@@ -168,6 +176,8 @@ TESTS_TARGETS = \
sign \
sodium_core \
sodium_utils \
+ sodium_utils2 \
+ sodium_utils3 \
sodium_version \
stream \
stream2 \
@@ -175,12 +185,6 @@ TESTS_TARGETS = \
stream4 \
verify1
-if !MINIMAL
-TESTS_TARGETS += \
- stream5 \
- stream6
-endif
-
check_PROGRAMS = $(TESTS_TARGETS)
TESTS = $(TESTS_TARGETS)
@@ -251,6 +255,9 @@ core5_LDADD = $(TESTS_LDADD)
core6_SOURCE = cmptest.h core6.c
core6_LDADD = $(TESTS_LDADD)
+ed25519_convert_SOURCE = cmptest.h ed25519_convert.c
+ed25519_convert_LDADD = $(TESTS_LDADD)
+
generichash_SOURCE = cmptest.h generichash.c
generichash_LDADD = $(TESTS_LDADD)
@@ -281,7 +288,7 @@ pwhash_LDADD = $(TESTS_LDADD)
pwhash_scrypt_ll_SOURCE = cmptest.h pwhash_scrypt_ll.c
pwhash_scrypt_ll_LDADD = $(TESTS_LDADD)
-randombytes_SOURCE = randombytes.c
+randombytes_SOURCE = cmptest.h randombytes.c
randombytes_LDADD = $(TESTS_LDADD)
scalarmult_SOURCE = cmptest.h scalarmult.c
@@ -296,6 +303,9 @@ scalarmult5_LDADD = $(TESTS_LDADD)
scalarmult6_SOURCE = cmptest.h scalarmult6.c
scalarmult6_LDADD = $(TESTS_LDADD)
+scalarmult7_SOURCE = cmptest.h scalarmult7.c
+scalarmult7_LDADD = $(TESTS_LDADD)
+
secretbox_SOURCE = cmptest.h secretbox.c
secretbox_LDADD = $(TESTS_LDADD)
@@ -326,6 +336,12 @@ sodium_core_LDADD = $(TESTS_LDADD)
sodium_utils_SOURCE = cmptest.h sodium_utils.c
sodium_utils_LDADD = $(TESTS_LDADD)
+sodium_utils2_SOURCE = cmptest.h sodium_utils2.c
+sodium_utils2_LDADD = $(TESTS_LDADD)
+
+sodium_utils3_SOURCE = cmptest.h sodium_utils3.c
+sodium_utils3_LDADD = $(TESTS_LDADD)
+
sodium_version_SOURCE = cmptest.h sodium_version.c
sodium_version_LDADD = $(TESTS_LDADD)
@@ -341,12 +357,6 @@ stream3_LDADD = $(TESTS_LDADD)
stream4_SOURCE = cmptest.h stream4.c
stream4_LDADD = $(TESTS_LDADD)
-stream5_SOURCE = cmptest.h stream5.c
-stream5_LDADD = $(TESTS_LDADD)
-
-stream6_SOURCE = cmptest.h stream6.c
-stream6_LDADD = $(TESTS_LDADD)
-
verify1_SOURCE = cmptest.h verify1.c
verify1_LDADD = $(TESTS_LDADD)