add deprecation notice
[leap_website.git] / Gemfile
1 source 'https://rubygems.org'
2
3 gem 'rails', '3.2.12'
4 gem 'sqlite3'
5 gem 'json'
6
7
8 gem 'haml'            # allow pages with .haml
9 gem 'RedCloth'        # allow :textile in HAML
10 gem 'sass-rails'      # not sure why can't be in :assets group
11 gem 'RbST'
12 gem 'rdiscount'
13
14 #gem 'pandoc-ruby'
15 #unless RUBY_VERSION =~ /1.8/
16 #  gem 'iconv'           # required for older pandoc
17 #end
18
19 # Gems used only for assets and not required
20 # in production environments by default.
21 group :assets do
22   gem 'font-awesome-sass'
23   gem 'uglifier', '>= 1.0.3'
24   gem 'execjs'  # See https://github.com/sstephenson/execjs#readme for supported runtimes
25   gem 'therubyracer', :platforms => :ruby
26   #gem 'therubyrhino', :platforms => :ruby
27 end
28
29 gem 'jquery-rails'
30 gem 'capistrano'     # deploy with Capistrano
31
32 group :development do
33   gem 'thin'
34   #gem 'debugger' -> you're probably on a too recent ruby
35   gem 'byebug'
36 end