moved source packages to virtualbox because they are only needed to compile vbox...
authorvarac <varacanero@zeromail.org>
Sat, 25 Apr 2015 18:37:39 +0000 (20:37 +0200)
committervarac <varacanero@zeromail.org>
Sat, 25 Apr 2015 18:37:39 +0000 (20:37 +0200)
definitions/wheezy/base.sh
definitions/wheezy/virtualbox.sh

index 81789db..b6c858e 100644 (file)
@@ -5,11 +5,7 @@ echo 'Acquire::PDiffs "false";' >/etc/apt/apt.conf.d/90disable-pdiffs
 
 # Update the box
 apt-get -y update
-apt-get -y install linux-headers-amd64 build-essential
-apt-get -y install zlib1g-dev libssl-dev libreadline6-dev
 apt-get -y install curl unzip
-# Debians virtualbox guest utilities are too old
-#apt-get -y install virtualbox-guest-utils
 apt-get -y install puppet ruby-hiera-puppet rsync lsb-release
 # Install additional packages to vagrant wheezy basebox to make beaker happy #6898
 apt-get -y install ntpdate git rdoc
index 818ca30..1a39803 100644 (file)
@@ -7,10 +7,13 @@ if test -f .vbox_version ; then
   rmmod vboxguest
   aptitude -y purge virtualbox-ose-guest-x11 virtualbox-ose-guest-dkms virtualbox-ose-guest-utils
 
-  # Install dkms for dynamic compiles
 
+  apt-get -y install linux-headers-amd64 build-essential
+  apt-get -y install zlib1g-dev libssl-dev libreadline6-dev
+
+  # Install dkms for dynamic compiles
   apt-get install -y dkms
-  
+
   # If libdbus is not installed, virtualbox will not autostart
   apt-get -y install --no-install-recommends libdbus-1-3