summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py72
1 files changed, 67 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 128861b..519ddb3 100644
--- a/setup.py
+++ b/setup.py
@@ -17,6 +17,7 @@
"""
setup file for leap.common
"""
+import re
from setuptools import setup, find_packages
from pkg import utils
@@ -46,18 +47,79 @@ trove_classifiers = [
"Topic :: Utilities"
]
+DOWNLOAD_BASE = ('https://github.com/leapcode/leap_pycommon/'
+ 'archive/%s.tar.gz')
+_versions = versioneer.get_versions()
+VERSION = _versions['version']
+VERSION_FULL = _versions['full']
+DOWNLOAD_URL = ""
+
+# get the short version for the download url
+_version_short = re.findall('\d+\.\d+\.\d+', VERSION)
+if len(_version_short) > 0:
+ VERSION_SHORT = _version_short[0]
+ DOWNLOAD_URL = DOWNLOAD_BASE % VERSION_SHORT
+
+cmdclass = versioneer.get_cmdclass()
+from setuptools import Command
+
+
+class freeze_debianver(Command):
+ """
+ Freezes the version in a debian branch.
+ To be used after merging the development branch onto the debian one.
+ """
+ user_options = []
+
+ def initialize_options(self):
+ pass
+
+ def finalize_options(self):
+ pass
+
+ def run(self):
+ proceed = str(raw_input(
+ "This will overwrite the file _version.py. Continue? [y/N] "))
+ if proceed != "y":
+ print("He. You scared. Aborting.")
+ return
+ template = r"""
+# This file was generated by the `freeze_debianver` command in setup.py
+# Using 'versioneer.py' (0.7+) from
+# revision-control system data, or from the parent directory name of an
+# unpacked source archive. Distribution tarballs contain a pre-generated copy
+# of this file.
+
+version_version = '{version}'
+version_full = '{version_full}'
+"""
+ templatefun = r"""
+
+def get_versions(default={}, verbose=False):
+ return {'version': version_version, 'full': version_full}
+"""
+ subst_template = template.format(
+ version=VERSION_SHORT,
+ version_full=VERSION_FULL) + templatefun
+ with open(versioneer.versionfile_source, 'w') as f:
+ f.write(subst_template)
+
+
+cmdclass["freeze_debianver"] = freeze_debianver
setup(
name='leap.common',
- version=versioneer.get_version(),
- cmdclass=versioneer.get_cmdclass(),
+ version=VERSION,
+ cmdclass=cmdclass,
url='https://leap.se/',
+ download_url=DOWNLOAD_URL,
license='GPLv3+',
author='The LEAP Encryption Access Project',
author_email='info@leap.se',
+ maintainer='Kali Kaneko',
+ maintainer_email='kali@leap.se',
description='Common files used by the LEAP project.',
- long_description=(
- "Common files used by the LEAP Client project."
- ),
+ long_description=open('README.rst').read() + '\n\n\n' +
+ open('CHANGELOG').read(),
classifiers=trove_classifiers,
namespace_packages=["leap"],
package_dir={'': 'src'},