summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--PKG-INFO20
-rwxr-xr-xdeb_release.sh8
-rw-r--r--debian/changelog80
-rw-r--r--debian/clean1
-rw-r--r--debian/compat1
-rw-r--r--debian/control15
-rw-r--r--debian/copyright16
-rwxr-xr-xdebian/rules7
-rw-r--r--debian/source/format1
-rw-r--r--setup.cfg5
-rw-r--r--src/leap/common/_version.py204
11 files changed, 156 insertions, 202 deletions
diff --git a/PKG-INFO b/PKG-INFO
new file mode 100644
index 0000000..a504e67
--- /dev/null
+++ b/PKG-INFO
@@ -0,0 +1,20 @@
+Metadata-Version: 1.1
+Name: leap.common
+Version: 0.2.5
+Summary: Common files used by the LEAP project.
+Home-page: https://leap.se/
+Author: The LEAP Encryption Access Project
+Author-email: info@leap.se
+License: GPLv3+
+Description: Common files used by the LEAP Client project.
+Platform: UNKNOWN
+Classifier: Development Status :: 3 - Alpha
+Classifier: Intended Audience :: Developers
+Classifier: License :: OSI Approved :: GNU General Public License v3 or later (GPLv3+)
+Classifier: Operating System :: OS Independent
+Classifier: Programming Language :: Python
+Classifier: Programming Language :: Python :: 2.6
+Classifier: Programming Language :: Python :: 2.7
+Classifier: Topic :: Communications
+Classifier: Topic :: Security
+Classifier: Topic :: Utilities
diff --git a/deb_release.sh b/deb_release.sh
new file mode 100755
index 0000000..9f0e675
--- /dev/null
+++ b/deb_release.sh
@@ -0,0 +1,8 @@
+#!/bin/zsh
+
+VERSION_FILE="src/leap/common/_version.py"
+rm ${VERSION_FILE}
+python setup.py freeze_debianver
+sed -i 's/-dirty//g' ${VERSION_FILE}
+git add ${VERSION_FILE}
+git ci -m "freeze debian version"
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..31e31e2
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,80 @@
+leap-common (0.3.9) unstable; urgency=medium
+
+ * Update to 0.3.9 release
+
+ -- Ben Carrillo <ben@futeisha.org> Fri, 07 Nov 2014 18:50:11 +0100
+
+leap-common (0.3.8) unstable; urgency=medium
+
+ * Update to 0.3.8 release
+
+ -- Ben Carrillo <ben@futeisha.org> Tue, 10 Jun 2014 09:24:12 -0500
+
+leap-common (0.3.7) unstable; urgency=low
+
+ * Update to 0.3.7 release
+
+ -- Ben Carrillo <ben@futeisha.org> Wed, 09 Apr 2014 14:26:10 -0500
+
+leap-common (0.3.6) unstable; urgency=low
+
+ * Update to 0.3.6 release
+
+ -- Micah Anderson <micah@debian.org> Tue, 10 Dec 2013 16:02:51 -0400
+
+leap-common (0.3.5) unstable; urgency=low
+
+ * Update to 0.3.5 release.
+
+ -- Micah Anderson <micah@debian.org> Tue, 05 Nov 2013 11:05:40 -0200
+
+leap-common (0.3.4) unstable; urgency=low
+
+ * Update to 0.3.4 release.
+ * Install LEAP changelog too.
+
+ -- Micah Anderson <micah@debian.org> Mon, 14 Oct 2013 03:40:42 -0300
+
+leap-common (0.3.3) unstable; urgency=low
+
+ * Update to 0.3.3 release.
+
+ -- Micah Anderson <micah@debian.org> Tue, 24 Sep 2013 17:02:57 -0400
+
+leap-common (0.3.2) unstable; urgency=low
+
+ * Update to 0.3.2
+
+ -- Ben Carrillo <ben@futeisha.org> Thu, 12 Sep 2013 14:00:01 +0200
+
+leap-common (0.3.1) unstable; urgency=low
+
+ * Update protobuf dependency to be more accurate
+ * Update to 0.3.1
+
+ -- Ben Carrillo <ben@futeisha.org> Mon, 26 Aug 2013 21:55:19 +0200
+
+leap-common (0.3.0.1) unstable; urgency=low
+
+ * Regenerate events_pb2.py with protobuf 2.4.1
+
+ -- Micah Anderson <micah@debian.org> Thu, 15 Aug 2013 10:11:43 -0400
+
+leap-common (0.3.0) unstable; urgency=low
+
+ * Update to 0.3.0
+
+ -- Micah Anderson <micah@debian.org> Tue, 13 Aug 2013 14:26:37 -0400
+
+leap-common (0.2.5) unstable; urgency=low
+
+ * Upgrade to 0.2.5
+ * Change to native package
+
+ -- Micah Anderson <micah@debian.org> Tue, 04 Jun 2013 16:16:29 -0400
+
+leap-common (0.2.3-dev1) unstable; urgency=low
+
+ * Initial debianization
+
+ -- Micah Anderson <micah@debian.org> Thu, 30 May 2013 14:06:16 -0400
diff --git a/debian/clean b/debian/clean
new file mode 100644
index 0000000..8dbc13e
--- /dev/null
+++ b/debian/clean
@@ -0,0 +1 @@
+src/leap.common.egg-info/*
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..ec63514
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+9
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..ce369f3
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,15 @@
+Source: leap-common
+Maintainer: Micah Anderson <micah@debian.org>
+Uploaders: Ben Carrillo <ben@futeisha.org>
+Section: python
+Priority: optional
+Build-Depends: python-setuptools (>= 0.6b3), python-all (>= 2.6.6-3), debhelper (>= 9), python-protobuf, python-protobuf.socketrpc
+Standards-Version: 3.9.5
+
+Package: python-leap-common
+Architecture: all
+Depends: ${misc:Depends}, ${python:Depends}, python-jsonschema, python-dirspec, python-protobuf (>=2.4.1), python-protobuf.socketrpc,
+ python-dateutil, python-openssl, python-gnupg
+Description: Common python files needed by LEAP projects.
+ This package contains common python functions that are needed
+ for the LEAP Client project
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..353207a
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,16 @@
+Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: leap-common
+Upstream-Contact: kali@leap.se
+Source: <git://code.leap.se/leap_pycommon/>
+
+Files: *
+Copyright: Copyright (C) 2013 LEAP
+License: GPL-3+
+
+Files: debian/*
+Copyright: Copyright 2013 Micah Anderson <micah@leap.se>
+License: GPL-3+
+
+License: GPL-3+
+ On Debian systems, the complete text of the GNU General
+ Public License can be found in `/usr/share/common-licenses/GPL'.
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..734e561
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,7 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@ --with python2 --buildsystem=python_distutils
+
+override_dh_installchangelogs:
+ dh_installchangelogs CHANGELOG
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..89ae9db
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)
diff --git a/setup.cfg b/setup.cfg
index 51070c6..d929797 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,3 +1,8 @@
+[egg_info]
+tag_build =
+tag_date = 0
+tag_svn_revision = 0
+
[aliases]
test = trial
diff --git a/src/leap/common/_version.py b/src/leap/common/_version.py
index de94ba8..3500492 100644
--- a/src/leap/common/_version.py
+++ b/src/leap/common/_version.py
@@ -1,203 +1,3 @@
-# This file helps to compute a version number in source trees obtained from
-# git-archive tarball (such as those provided by githubs download-from-tag
-# feature). Distribution tarballs (build by setup.py sdist) and build
-# directories (produced by setup.py build) will contain a much shorter file
-# that just contains the computed version number.
-# This file is released into the public domain. Generated by
-# versioneer-0.7+ (https://github.com/warner/python-versioneer)
-
-# these strings will be replaced by git during git-archive
-
-import subprocess
-import sys
-import re
-import os.path
-
-IN_LONG_VERSION_PY = True
-git_refnames = "$Format:%d$"
-git_full = "$Format:%H$"
-
-
-def run_command(args, cwd=None, verbose=False):
- try:
- # remember shell=False, so use git.cmd on windows, not just git
- p = subprocess.Popen(args, stdout=subprocess.PIPE, cwd=cwd)
- except EnvironmentError:
- e = sys.exc_info()[1]
- if verbose:
- print("unable to run %s" % args[0])
- print(e)
- return None
- stdout = p.communicate()[0].strip()
- if sys.version >= '3':
- stdout = stdout.decode()
- if p.returncode != 0:
- if verbose:
- print("unable to run %s (error)" % args[0])
- return None
- return stdout
-
-
-def get_expanded_variables(versionfile_source):
- # the code embedded in _version.py can just fetch the value of these
- # variables. When used from setup.py, we don't want to import
- # _version.py, so we do it with a regexp instead. This function is not
- # used from _version.py.
- variables = {}
- try:
- f = open(versionfile_source, "r")
- for line in f.readlines():
- if line.strip().startswith("git_refnames ="):
- mo = re.search(r'=\s*"(.*)"', line)
- if mo:
- variables["refnames"] = mo.group(1)
- if line.strip().startswith("git_full ="):
- mo = re.search(r'=\s*"(.*)"', line)
- if mo:
- variables["full"] = mo.group(1)
- f.close()
- except EnvironmentError:
- pass
- return variables
-
-
-def versions_from_expanded_variables(variables, tag_prefix, verbose=False):
- refnames = variables["refnames"].strip()
- if refnames.startswith("$Format"):
- if verbose:
- print("variables are unexpanded, not using")
- return {} # unexpanded, so not in an unpacked git-archive tarball
- refs = set([r.strip() for r in refnames.strip("()").split(",")])
- # starting in git-1.8.3, tags are listed as "tag: foo-1.0" instead of
- # just "foo-1.0". If we see a "tag: " prefix, prefer those.
- TAG = "tag: "
- tags = set([r[len(TAG):] for r in refs if r.startswith(TAG)])
- if not tags:
- # Either we're using git < 1.8.3, or there really are no tags. We use
- # a heuristic: assume all version tags have a digit. The old git %d
- # expansion behaves like git log --decorate=short and strips out the
- # refs/heads/ and refs/tags/ prefixes that would let us distinguish
- # between branches and tags. By ignoring refnames without digits, we
- # filter out many common branch names like "release" and
- # "stabilization", as well as "HEAD" and "master".
- tags = set([r for r in refs if re.search(r'\d', r)])
- if verbose:
- print("discarding '%s', no digits" % ",".join(refs - tags))
- if verbose:
- print("likely tags: %s" % ",".join(sorted(tags)))
- for ref in sorted(tags):
- # sorting will prefer e.g. "2.0" over "2.0rc1"
- if ref.startswith(tag_prefix):
- r = ref[len(tag_prefix):]
- if verbose:
- print("picking %s" % r)
- return {"version": r,
- "full": variables["full"].strip()}
- # no suitable tags, so we use the full revision id
- if verbose:
- print("no suitable tags, using full revision id")
- return {"version": variables["full"].strip(),
- "full": variables["full"].strip()}
-
-
-def versions_from_vcs(tag_prefix, versionfile_source, verbose=False):
- # this runs 'git' from the root of the source tree. That either means
- # someone ran a setup.py command (and this code is in versioneer.py, so
- # IN_LONG_VERSION_PY=False, thus the containing directory is the root of
- # the source tree), or someone ran a project-specific entry point (and
- # this code is in _version.py, so IN_LONG_VERSION_PY=True, thus the
- # containing directory is somewhere deeper in the source tree). This only
- # gets called if the git-archive 'subst' variables were *not* expanded,
- # and _version.py hasn't already been rewritten with a short version
- # string, meaning we're inside a checked out source tree.
-
- try:
- here = os.path.abspath(__file__)
- except NameError:
- # some py2exe/bbfreeze/non-CPython implementations don't do __file__
- return {} # not always correct
-
- # versionfile_source is the relative path from the top of the source tree
- # (where the .git directory might live) to this file. Invert this to find
- # the root from __file__.
- root = here
- if IN_LONG_VERSION_PY:
- for i in range(len(versionfile_source.split("/"))):
- root = os.path.dirname(root)
- else:
- root = os.path.dirname(here)
- if not os.path.exists(os.path.join(root, ".git")):
- if verbose:
- print("no .git in %s" % root)
- return {}
-
- GIT = "git"
- if sys.platform == "win32":
- GIT = "git.cmd"
- stdout = run_command([GIT, "describe", "--tags", "--dirty", "--always"],
- cwd=root)
- if stdout is None:
- return {}
- if not stdout.startswith(tag_prefix):
- if verbose:
- print("tag '%s' doesn't start with prefix '%s'" % (stdout, tag_prefix))
- return {}
- tag = stdout[len(tag_prefix):]
- stdout = run_command([GIT, "rev-parse", "HEAD"], cwd=root)
- if stdout is None:
- return {}
- full = stdout.strip()
- if tag.endswith("-dirty"):
- full += "-dirty"
- return {"version": tag, "full": full}
-
-
-def versions_from_parentdir(parentdir_prefix, versionfile_source, verbose=False):
- if IN_LONG_VERSION_PY:
- # We're running from _version.py. If it's from a source tree
- # (execute-in-place), we can work upwards to find the root of the
- # tree, and then check the parent directory for a version string. If
- # it's in an installed application, there's no hope.
- try:
- here = os.path.abspath(__file__)
- except NameError:
- # py2exe/bbfreeze/non-CPython don't have __file__
- return {} # without __file__, we have no hope
- # versionfile_source is the relative path from the top of the source
- # tree to _version.py. Invert this to find the root from __file__.
- root = here
- for i in range(len(versionfile_source.split("/"))):
- root = os.path.dirname(root)
- else:
- # we're running from versioneer.py, which means we're running from
- # the setup.py in a source tree. sys.argv[0] is setup.py in the root.
- here = os.path.abspath(sys.argv[0])
- root = os.path.dirname(here)
-
- # Source tarballs conventionally unpack into a directory that includes
- # both the project name and a version string.
- dirname = os.path.basename(root)
- if not dirname.startswith(parentdir_prefix):
- if verbose:
- print("guessing rootdir is '%s', but '%s' doesn't start with prefix '%s'" %
- (root, dirname, parentdir_prefix))
- return None
- return {"version": dirname[len(parentdir_prefix):], "full": ""}
-
-tag_prefix = ""
-parentdir_prefix = "leap.common-"
-versionfile_source = "src/leap/common/_version.py"
-
-
-def get_versions(default={"version": "unknown", "full": ""}, verbose=False):
- variables = {"refnames": git_refnames, "full": git_full}
- ver = versions_from_expanded_variables(variables, tag_prefix, verbose)
- if not ver:
- ver = versions_from_vcs(tag_prefix, versionfile_source, verbose)
- if not ver:
- ver = versions_from_parentdir(parentdir_prefix, versionfile_source,
- verbose)
- if not ver:
- ver = default
- return ver
+version_version = '0.3.9'
+version_full = '3de1eeba83d50793283d65ba4566dd1611ee9d4b'