[pkg] add script to install base requirements
authorKali Kaneko <kali@leap.se>
Tue, 28 Jul 2015 01:42:47 +0000 (21:42 -0400)
committerKali Kaneko <kali@leap.se>
Tue, 28 Jul 2015 01:42:47 +0000 (21:42 -0400)
- update pip
- install base reqs, with insecure flags for dirspec. fuck canonical.

pkg/pip_install_requirements.sh [new file with mode: 0755]

diff --git a/pkg/pip_install_requirements.sh b/pkg/pip_install_requirements.sh
new file mode 100755 (executable)
index 0000000..8576c8c
--- /dev/null
@@ -0,0 +1,6 @@
+#!/bin/sh
+# Update pip and install LEAP base requirements.
+# For convenience, u1db and dirspec are allowed with insecure flags enabled.
+# Use at your own risk.
+pip install -U pip
+pip install --allow-external dirspec --allow-unverified dirspec -r pkg/requirements.pip