[style] pep8 fixes
authorKali Kaneko <kali@leap.se>
Fri, 28 Aug 2015 16:10:41 +0000 (12:10 -0400)
committerKali Kaneko <kali@leap.se>
Fri, 28 Aug 2015 16:10:41 +0000 (12:10 -0400)
setup.cfg
setup.py

index 51070c6..4a2ab2b 100644 (file)
--- a/setup.cfg
+++ b/setup.cfg
@@ -2,9 +2,9 @@
 test = trial
 
 [pep8]
-exclude = versioneer.py,_version.py,*.egg,build,docs
+exclude = versioneer.py,_version.py,*.egg,build,dist,docs
 ignore = E731
 
 [flake8]
-exclude = versioneer.py,_version.py,*.egg,build,docs
+exclude = versioneer.py,_version.py,*.egg,build,dist,docs
 ignore = E731
index ca83017..ae0ec63 100644 (file)
--- a/setup.py
+++ b/setup.py
@@ -19,9 +19,9 @@ setup file for leap.common
 """
 import re
 from setuptools import setup, find_packages
+from setuptools import Command
 
 from pkg import utils
-parsed_reqs = utils.parse_requirements()
 
 import versioneer
 versioneer.versionfile_source = 'src/leap/common/_version.py'
@@ -29,6 +29,8 @@ versioneer.versionfile_build = 'leap/common/_version.py'
 versioneer.tag_prefix = ''  # tags are like 1.2.0
 versioneer.parentdir_prefix = 'leap.common-'
 
+parsed_reqs = utils.parse_requirements()
+
 tests_requirements = [
     'mock',
 ]
@@ -61,7 +63,6 @@ if len(_version_short) > 0:
     DOWNLOAD_URL = DOWNLOAD_BASE % VERSION_SHORT
 
 cmdclass = versioneer.get_cmdclass()
-from setuptools import Command
 
 
 class freeze_debianver(Command):
@@ -130,11 +131,11 @@ setup(
     package_data={'': ['*.pem']},
     # For now, we do not exclude tests because of the circular dependency
     # between leap.common and leap.soledad.
-    #packages=find_packages('src', exclude=['leap.common.tests']),
+    # packages=find_packages('src', exclude=['leap.common.tests']),
     packages=find_packages('src'),
     test_suite='leap.common.tests',
     install_requires=parsed_reqs,
-    #dependency_links=dependency_links,
+    # dependency_links=dependency_links,
     tests_require=tests_requirements,
     include_package_data=True,
     zip_safe=False,
@@ -143,6 +144,6 @@ setup(
         # needed for leap.common.http
         #  service_identity needed for propper hostname identification,
         #  see http://twistedmatrix.com/documents/current/core/howto/ssl.html
-        'Twisted':  ["Twisted>=14.0.2", "service_identity", "zope.interface"]
+        'Twisted': ["Twisted>=14.0.2", "service_identity", "zope.interface"]
     },
 )