summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRuben Pollan <meskio@sindominio.net>2015-06-03 00:29:13 +0200
committerRuben Pollan <meskio@sindominio.net>2015-06-03 00:29:13 +0200
commita61e70dcd9a65b23e3775bee9221d6a273ada510 (patch)
tree37041b527b6be4acddcad4843ffc654546c2c414 /setup.py
parent7826a96e526a450380917f9b89e3714576ca50b7 (diff)
parentbf18c2bc6e3f533187281a3b31febd37ef22f8c0 (diff)
Merge branch 'shyba/feat/twisted_http_get' into develop
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 7 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index a7de8f9..776a477 100644
--- a/setup.py
+++ b/setup.py
@@ -138,4 +138,11 @@ setup(
tests_require=tests_requirements,
include_package_data=True,
zip_safe=False,
+
+ extras_require={
+ # needed for leap.common.http
+ # service_identity needed for propper hostname identification,
+ # see http://twistedmatrix.com/documents/current/core/howto/ssl.html
+ 'Twisted': ["Twisted>=14.0.2", "service_identity", "zope.insterface"]
+ },
)