summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruno Wagner <bwagner@riseup.net>2016-03-10 16:04:57 -0300
committerBruno Wagner <bwagner@riseup.net>2016-03-10 16:04:57 -0300
commit77ff0a10eb83263fdfb94e0bc9b1a38fd7e434f8 (patch)
tree3f66625daa0a6d32245793bf483bc93d0daf7bac
parent4fb7e8724302f4fe30891b6132e9b85472d42708 (diff)
[setup] Added docs on how to run the tests
Also added dirspec directly to the setuptools for now, because it needs the dependency along with the url, but pip would break if it had both
-rw-r--r--README.rst14
-rw-r--r--pkg/requirements.pip1
-rw-r--r--setup.py1
3 files changed, 15 insertions, 1 deletions
diff --git a/README.rst b/README.rst
index 349edce..f46b70e 100644
--- a/README.rst
+++ b/README.rst
@@ -29,3 +29,17 @@ Using `leap.common.http` needs some extra dependencies (twisted.web >= 14.0.2,
python-service-identity). You can install them by running::
pip install leap.common[http]
+
+
+Running the tests
+-------------------
+To run the tests, first run the setup with:
+
+.. code-block::
+pip install -r pkg/requirements.pip
+pip install -r pkg/requirements-testing.pip
+
+After that you can run the tests with
+
+.. code-block::
+trial leap.common
diff --git a/pkg/requirements.pip b/pkg/requirements.pip
index bbf60f1..b2be31f 100644
--- a/pkg/requirements.pip
+++ b/pkg/requirements.pip
@@ -4,5 +4,4 @@ python-dateutil
pyzmq>=14.4.1
txzmq>=0.7.3
https://launchpad.net/dirspec/stable-13-10/13.10/+download/dirspec-13.10.tar.gz
-dirspec
-e .
diff --git a/setup.py b/setup.py
index 22a4a59..1e77828 100644
--- a/setup.py
+++ b/setup.py
@@ -33,6 +33,7 @@ requirements = utils.parse_requirements()
dependency_links = [requirement for requirement in requirements if requirement.startswith('http')]
requirements = [requirement for requirement in requirements if requirement not in dependency_links]
+requirements.append('dirspec')
tests_requirements = [
'mock',