summaryrefslogtreecommitdiff
path: root/pkg/leap_mx
diff options
context:
space:
mode:
authordrebs <drebs@leap.se>2015-04-23 12:23:21 -0300
committerdrebs <drebs@leap.se>2015-04-24 10:55:45 -0300
commitda08ab21bc56a0905db8697032ee1fcbef6298f7 (patch)
treefe962e51725b5e4975c21658dde4d1e111a1db04 /pkg/leap_mx
parent799703cf884191d097eb5d5316fa964e421683fd (diff)
[pkg] remove initscript from python package
There are some reasons to remove the initscript from the python package: 1. To include the initscript it in the python package it is necessary to assume a lot of things about the system in which the package would be installed. 2. The debian packaging system will correctly create an initscript by itself. 3. We don't have to maintain 2 different setup.py files (one in master/develop branch and another in debian package branches).
Diffstat (limited to 'pkg/leap_mx')
-rw-r--r--pkg/leap_mx66
1 files changed, 0 insertions, 66 deletions
diff --git a/pkg/leap_mx b/pkg/leap_mx
deleted file mode 100644
index 60dddc4..0000000
--- a/pkg/leap_mx
+++ /dev/null
@@ -1,66 +0,0 @@
-#!/bin/sh
-### BEGIN INIT INFO
-# Provides: leap-mx
-# Required-Start: $network $named $remote_fs $syslog $time
-# Required-Stop: $network $named $remote_fs $syslog
-# Default-Start: 2 3 4 5
-# Default-Stop: 0 1 6
-# Short-Description: Start leap-mx daemon at boot time
-# Description: transparently-encrypting remailer
-### END INIT INFO
-
-PATH=/sbin:/bin:/usr/sbin:/usr/bin
-PIDFILE=/var/run/leap_mx.pid
-RUNDIR=/var/lib/leap_mx/
-FILE=/usr/share/app/leap_mx.tac
-LOGFILE=/var/log/leap_mx.log
-TWISTD_PATH=/usr/bin/twistd
-
-[ -r /etc/default/leap_mx ] && . /etc/default/leap_mx
-
-. /lib/lsb/init-functions
-
-test -r $file || exit 0
-test -r /etc/leap/ || exit 0
-
-
-case "$1" in
- start)
- echo -n "Starting leap_mx: twistd"
- HOME="/var/lib/leap_mx/" \
- start-stop-daemon --start --quiet --exec $TWISTD_PATH -- \
- --pidfile=$PIDFILE \
- --rundir=$RUNDIR \
- --python=$FILE \
- --logfile=$LOGFILE \
- --syslog --prefix=leap-mx
- echo "."
- ;;
-
- stop)
- echo -n "Stopping leap_mx: twistd"
- start-stop-daemon --stop --quiet \
- --pidfile $PIDFILE
- echo "."
- ;;
-
- restart)
- $0 stop
- $0 start
- ;;
-
- force-reload)
- $0 restart
- ;;
-
- status)
- status_of_proc -p $PIDFILE $TWISTD_PATH leap_mx && exit 0 || exit $?
- ;;
-
- *)
- echo "Usage: /etc/init.d/leap_mx {start|stop|restart|force-reload|status}" >&2
- exit 1
- ;;
-esac
-
-exit 0