summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMicah Anderson <micah@riseup.net>2013-08-13 16:34:24 -0400
committerMicah Anderson <micah@riseup.net>2013-08-14 11:29:29 -0400
commit82e25b14f1c0f6d07758f1d91a7da8474d682f1c (patch)
tree85bb6aab76192231612eada3744ee7595979544b
parent80795ab3e08e2426b919d37896015fb78326c0cb (diff)
fix initscript variables
-rw-r--r--debian/changelog6
-rw-r--r--debian/leap-mx.init12
2 files changed, 12 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index e7c7958..75ad370 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+leap-mx (0.3.0.2) unstable; urgency=low
+
+ * Fix initscript variables
+
+ -- Micah Anderson <micah@debian.org> Tue, 13 Aug 2013 16:33:45 -0400
+
leap-mx (0.3.0.1) unstable; urgency=low
* Require twisted >=13.0.0-1~bpo70
diff --git a/debian/leap-mx.init b/debian/leap-mx.init
index 3f07a86..3b454d0 100644
--- a/debian/leap-mx.init
+++ b/debian/leap-mx.init
@@ -28,18 +28,18 @@ case "$1" in
start)
echo -n "Starting leap_mx: twistd"
HOME="/var/lib/leap_mx/" \
- start-stop-daemon --start --quiet --exec $twistd_path -- \
- --pidfile=$pidfile \
- --rundir=$rundir \
- --python=$file \
- --logfile=$logfile
+ start-stop-daemon --start --quiet --exec $TWISTD_PATH -- \
+ --pidfile=$PIDFILE \
+ --rundir=$RUNDIR \
+ --python=$FILE \
+ --logfile=$LOGFILE
echo "."
;;
stop)
echo -n "Stopping leap_mx: twistd"
start-stop-daemon --stop --quiet \
- --pidfile $pidfile
+ --pidfile $PIDFILE
echo "."
;;