summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMicah Anderson <micah@riseup.net>2015-01-12 14:26:18 -0500
committerMicah Anderson <micah@riseup.net>2015-01-12 14:26:18 -0500
commit85680ed4053aca4794cd88f75388c56c350fc466 (patch)
tree68d5edc547a54a7b817d72c0e17bc856db256e6e
parent7e5f325c7007d266361032605840629ecab2ba67 (diff)
sync upstream initscript and custom debian one, adding syslog options
-rw-r--r--debian/changelog7
l---------[-rw-r--r--]debian/leap-mx.init66
-rw-r--r--pkg/leap_mx66
3 files changed, 74 insertions, 65 deletions
diff --git a/debian/changelog b/debian/changelog
index 1c25adb..49480f8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+leap-mx (0.6.0.1) unstable; urgency=medium
+
+ * Sync upstream initscript and ours, adding syslog options
+ to better handle logging (#4599, #6307)
+
+ -- Micah Anderson <micah@debian.org> Mon, 12 Jan 2015 14:25:16 -0500
+
leap-mx (0.6.0) unstable; urgency=medium
* Update to 0.6.0 version
diff --git a/debian/leap-mx.init b/debian/leap-mx.init
index 3b454d0..b4022e6 100644..120000
--- a/debian/leap-mx.init
+++ b/debian/leap-mx.init
@@ -1,65 +1 @@
-#!/bin/sh
-### BEGIN INIT INFO
-# Provides: leap-mx
-# Required-Start: $network $named $remote_fs $syslog $time
-# Required-Stop: $network $named $remote_fs $syslog
-# Default-Start: 2 3 4 5
-# Default-Stop: 0 1 6
-# Short-Description: Start leap-mx daemon at boot time
-# Description: transparently-encrypting remailer
-### END INIT INFO
-
-PATH=/sbin:/bin:/usr/sbin:/usr/bin
-PIDFILE=/var/run/leap_mx.pid
-RUNDIR=/var/lib/leap_mx/
-FILE=/usr/share/app/leap_mx.tac
-LOGFILE=/var/log/leap_mx.log
-TWISTD_PATH=/usr/bin/twistd
-
-[ -r /etc/default/leap_mx ] && . /etc/default/leap_mx
-
-. /lib/lsb/init-functions
-
-test -r $file || exit 0
-test -r /etc/leap/ || exit 0
-
-
-case "$1" in
- start)
- echo -n "Starting leap_mx: twistd"
- HOME="/var/lib/leap_mx/" \
- start-stop-daemon --start --quiet --exec $TWISTD_PATH -- \
- --pidfile=$PIDFILE \
- --rundir=$RUNDIR \
- --python=$FILE \
- --logfile=$LOGFILE
- echo "."
- ;;
-
- stop)
- echo -n "Stopping leap_mx: twistd"
- start-stop-daemon --stop --quiet \
- --pidfile $PIDFILE
- echo "."
- ;;
-
- restart)
- $0 stop
- $0 start
- ;;
-
- force-reload)
- $0 restart
- ;;
-
- status)
- status_of_proc -p $PIDFILE $TWISTD_PATH leap_mx && exit 0 || exit $?
- ;;
-
- *)
- echo "Usage: /etc/init.d/leap_mx {start|stop|restart|force-reload|status}" >&2
- exit 1
- ;;
-esac
-
-exit 0
+../pkg/leap_mx \ No newline at end of file
diff --git a/pkg/leap_mx b/pkg/leap_mx
new file mode 100644
index 0000000..60dddc4
--- /dev/null
+++ b/pkg/leap_mx
@@ -0,0 +1,66 @@
+#!/bin/sh
+### BEGIN INIT INFO
+# Provides: leap-mx
+# Required-Start: $network $named $remote_fs $syslog $time
+# Required-Stop: $network $named $remote_fs $syslog
+# Default-Start: 2 3 4 5
+# Default-Stop: 0 1 6
+# Short-Description: Start leap-mx daemon at boot time
+# Description: transparently-encrypting remailer
+### END INIT INFO
+
+PATH=/sbin:/bin:/usr/sbin:/usr/bin
+PIDFILE=/var/run/leap_mx.pid
+RUNDIR=/var/lib/leap_mx/
+FILE=/usr/share/app/leap_mx.tac
+LOGFILE=/var/log/leap_mx.log
+TWISTD_PATH=/usr/bin/twistd
+
+[ -r /etc/default/leap_mx ] && . /etc/default/leap_mx
+
+. /lib/lsb/init-functions
+
+test -r $file || exit 0
+test -r /etc/leap/ || exit 0
+
+
+case "$1" in
+ start)
+ echo -n "Starting leap_mx: twistd"
+ HOME="/var/lib/leap_mx/" \
+ start-stop-daemon --start --quiet --exec $TWISTD_PATH -- \
+ --pidfile=$PIDFILE \
+ --rundir=$RUNDIR \
+ --python=$FILE \
+ --logfile=$LOGFILE \
+ --syslog --prefix=leap-mx
+ echo "."
+ ;;
+
+ stop)
+ echo -n "Stopping leap_mx: twistd"
+ start-stop-daemon --stop --quiet \
+ --pidfile $PIDFILE
+ echo "."
+ ;;
+
+ restart)
+ $0 stop
+ $0 start
+ ;;
+
+ force-reload)
+ $0 restart
+ ;;
+
+ status)
+ status_of_proc -p $PIDFILE $TWISTD_PATH leap_mx && exit 0 || exit $?
+ ;;
+
+ *)
+ echo "Usage: /etc/init.d/leap_mx {start|stop|restart|force-reload|status}" >&2
+ exit 1
+ ;;
+esac
+
+exit 0